Outils pour utilisateurs

Outils du site


lmde:mettre_a_jour_sa_lmde

Quelques rappels

Si une nouvelle version, d'un paquet installé sur votre ordinateur, est mise à disposition, vous pouvez la mettre à jour. Celle-ci peut être une mise à jour de sécurité pour des éléments du système d’exploitation, ou celle-ci peut être une optimisation dans une bibliothèque spécifique, ou même être une nouvelle version de « Firefox ».

Vous pourriez utiliser APT pour mettre à jour tous vos paquets avec une simple commande (« apt upgrade »), mais nous vous recommandons fortement de ne pas le faire.

Certains recommandent l'utilisation de APT et de ses frères (apt-get, aptitude) en lieu et place de mintupdate, arguant d'une fiabilité supposée douteuse de cet outil. Chacun est libre de ses choix et si vous souhaitez partir sur cette voie, voici un tutoriel sur APT qui vous aidera.

ATTENTION TOUT DE MÊME: En effectuant les mises à jour directement en ligne de commande, il n'y a plus d'intermédiaire. Vous êtes en contrôle total.

La raison est, que ces outils ne feront aucun tri dans la liste des mises à jour disponibles, et ils supposeront que vous voulez toutes les appliquer.

Certains parties du système peuvent être mises à jour sans danger et d'autres non. Par exemple, en mettant à jour votre noyau (la partie qui est responsable, entre autres, de la reconnaissance du matériel), vous pourriez perdre le support audio, la prise en compte de votre carte Wi-fi ou même des applications (telles que Vmware ou Virtualbox) qui sont étroitement liées au noyau.

Le gestionnaire de mises à jour

Présentation de l'outil

Linux Mint inclut un outil appelé le Gestionnaire de mises à jour. Il vous fournit des informations supplémentaires à propos des mises à jour disponibles.

Comme pour les éditions Linux Mint basées sur Ubuntu, des niveaux de stabilité sont attribués à chaque mise à jour de paquet, de 1 (directement issue du Paradis) à 5 (carrément échappée de la maison concurrente étant donnée la menace pour votre âme et votre système).

Fonctionnement

En mode actif minimisé, le gestionnaire de mises à jour a l'apparence d'un bouclier et se trouve dans la zone de notifications (normalement dans le coin inférieur droit de votre écran si vous n'avez rien changé). Si vous placez votre pointeur de souris dessus, il vous indiquera si votre système est à jour ou, si ce n'est pas le cas, combien de mises à jour sont disponibles.

Si vous cliquez sur le bouclier, le gestionnaire de mises à jour s'ouvre et affiche les mises à jour disponibles. L'interface est très simple d'utilisation.

 gestionnaire de mises à jour dans LMDE

Pour chaque mise à jour de paquet, une description est disponible, ainsi qu'une liste des changements effectués (notes des développeurs expliquant les modifications apportées au paquet), et une indication sur le fait que Linux Mint a ajouté des avertissements ou des informations supplémentaires à propos de ces mises à jour.

Vous pouvez également voir quelle version est disponible pour la mettre à jour.

Paramétrage : Édition > Préférences

 paramétrage du gestionnaire

L'onglet « Niveaux »

Vous indique les différents niveaux de tests effectués par l'équipe de Linux Mint et leur possible impact sur votre système.

  • « Sûr ? » : les mises à jour des paquets des niveaux concernés seront automatiquement sélectionnées par défaut.
  • « Visible ? » : les mises à jours seront visibles dans le gestionnaire.
  • « Toujours montrer les mises à jour de sécurité » : vous affichera toutes les mises à jour de sécurité tous niveaux confondus même pour un niveau non choisi comme « visible » (Par exemple une mise à jour de sécurité d'un paquet de niveau 4 apparaitra même si la case « Visible ? » n'avait pas été cochée).
  • « Toujours cocher les mises à jour de sécurité » : celles-ci seront cochées par défaut.

L'onglet « Rafraichissement automatique »

Vous permet de définir la fréquence des recherches de mises à jour par le gestionnaire de mises à jour.

L'onglet « Méthode de Mise à jour »

Vous permet de définir la façon dont le gestionnaire de mises à jour recherche les mises à jour.

  • L'option « inclure les mises à jour qui nécessitent l'installation de nouveaux paquets ou la suppression de paquets installés » vous permet de définir si le gestionnaire de mises à jour doit installer de nouvelles dépendances ou pas. Par exemple, si un paquet A est installé sur votre ordinateur, et qu'un paquet A version 2 est disponible, mais que celui-ci possède une nouvelle dépendance avec le paquet B qui n'est pas installé sur votre ordinateur… que va-t-il se passer ?
  • Si vous n'avez pas coché cette case, le paquet A version 2 n'apparaîtra pas dans la liste des mises à jour disponibles.Si vous l'avez cochée, il sera affiché, et si vous le sélectionnez, il installera le paquet B en tant que dépendance.Soyez prudent(e) avec cette option, car les dépendances peuvent installer de nouveaux paquets sur votre compte, mais elles peuvent également supprimer des paquets que vous avez déjà installés.

L'onglet « Paquets ignorés »

Vous pouvez y définir les paquets pour lesquels vous ne souhaitez pas recevoir de proposition de mises à jour. Les caractères spéciaux « ? » et « * » sont reconnus et pris en compte.

L'onglet « icônes »

Vous permet de changer les icônes utilisées par le gestionnaire de mises à jour dans la zone de notifications (en bas à droite de l'écran par défaut).

Si vous rencontrez des problèmes avec le gestionnaire de mises à jour (« impossible d'actualiser la liste des paquets », par exemple), vous pouvez consulter le fichier journal concernant celui-ci. Faites un clic-droit sur l'icône du bouclier dans la zone de notification, et sélectionnez « Information ».

lmde/mettre_a_jour_sa_lmde.txt · Dernière modification: 2016/03/19 07:28 par wizard97_4